Service Disruption
Incident Report for Tricentis Flood
Resolved
This incident has been resolved.
Posted Feb 05, 2020 - 01:27 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2020 - 22:36 AEST
Investigating
We are currently investigating a temporary disruption in service. Please, be patient while we establish root cause.
Posted Feb 04, 2020 - 22:16 AEST
This incident affected: Dashboard and API.