Flood service interruption
Incident Report for Tricentis Flood
Resolved
This incident has been resolved.
Posted about 2 years ago. Mar 24, 2017 - 09:03 AEST
Monitoring
We have since allocated more resources to match the unexpected demand and will continue to monitor.
Posted about 2 years ago. Mar 24, 2017 - 08:01 AEST
Investigating
We're investigating high volume load affecting our dashboard and API at the moment.
Posted about 2 years ago. Mar 24, 2017 - 06:58 AEST