Outage affecting main site
Incident Report for Tricentis Flood
Resolved
The underlying data issue causing this has since been found and fixed.
Posted almost 2 years ago. May 04, 2017 - 23:20 AEST
Investigating
We are experiencing intermittent outages at present on the main site due to a data issue. Root cause is known and we are expediting a fix.
Posted almost 2 years ago. May 04, 2017 - 22:55 AEST