Grids not launching
Incident Report for Tricentis Flood
Resolved
We have identified root cause and fixed this in production. Apologies for the short delay!
Posted May 30, 2019 - 04:36 AEST
Investigating
We are currently investigating issues with Grid launch.
Posted May 30, 2019 - 04:29 AEST
This incident affected: Grids.