Slow results
Incident Report for Tricentis Flood
Resolved
Backlog has since been cleared. Thank you for your patience.
Posted almost 2 years ago. Oct 20, 2017 - 01:05 AEST
Identified
We have identified the issue in our infrastructure and are now clearing the backlog. Results should be back soon.
Posted almost 2 years ago. Oct 20, 2017 - 00:56 AEST
Investigating
We are currently investigating reports of slow results in the European region and will post back here with findings.
Posted almost 2 years ago. Oct 20, 2017 - 00:51 AEST